Forum > Other Games

A LAMP question: developing in Apache2 for an Apache1 environment?

(1/1)

Enkhidu:
I'm a bit of a LAMP n00b, and was wondering if anyone could shed some light on a subject for me.

I'd like to be able to do some development on my Ubuntu box, but at heart I'm a bit lazy and would like to use the Apache2 package provided in the Breezy build, and the eventual resting place for the code will be Apache 1.3.33.

I'm not sure how this would affect behavior of my code - has anyone tried this, and if so with what success/failure?

Guest (Deleted):
I will... concentrate... hard... to give the right answer....

The script processing engine has more effect on whether it will run than the web server. - For example: the most current version of PHP in LAMPP is 5.x series, so if you backport it to a server running PHP 4.x (likely if it's Apache 1) you could very well run into problems - especially if you are using OOP methods since PHP 4 and 5 handle them differently.

Enkhidu:
Thanks, Pookie. I'll be sure to do the opposite of everything you just said.

Seriously, I'm actually taking a third route and trying to do some of this on a WAMP set. I can't see it being a problem beyond maybe a handful of changes to a few .php files.

Thanks!

Guest (Deleted):
Just remember this - 90% of PHP 4 script runs on PHP 5. It's that last 10% that will have you slamming your head violently into the keyboard.

Navigation

[0] Message Index

Go to full version